Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Stiff configure error
03-21-2014, 16:29
Post: #1
Stiff configure error
Hi

I just wanted to update to the latest Stiff version on Mac OS 10.9.2, but I noticed a configuration error:

...
checking for jpeg_start_decompress in -ljpeg... no
configure: error: Exiting.

My jpeg library works fine with v2.1.3, I just tried to compile it again. Not sure where the error lies, but I hope this helps anyway.

cheers
Find all posts by this user
Quote this message in a reply
05-16-2014, 14:24
Post: #2
RE: Stiff configure error
Hi Stefan

I managed to compile STIFF in Maverick with the configure flags listed below (I installed the tiff and jpeg libraries, as well as the C compiler, with MacPorts).
You may wish to change the installation directory pointed to by the prefix flag.

Cheers

Nicola

Code:
export CC="/opt/local/bin/gcc"
export LDFLAGS="-L/opt/local/lib"
make distclean
./configure --prefix=/usr/pkg/stiff-2.4.0         \
            --with-tiff-incdir=/opt/local/include \
            --with-tiff-libdir=/opt/local/lib     \
            --with-jpeg-libdir=/opt/local/lib     \
            --with-z-libdir=/opt/local/lib        \
            >&  configure.spool &
Find all posts by this user
Quote this message in a reply
05-16-2014, 21:51
Post: #3
RE: Stiff configure error
That was the key:

export LDFLAGS="-L/opt/local/lib"

Thanks a lot!! Smile
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)