Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Wrong computed magnitudes by SkyMaker ??
02-14-2012, 21:12 (This post was last modified: 02-16-2012 14:17 by JVarela.)
Post: #1
Wrong computed magnitudes by SkyMaker ??
[Update: There is no problem with SkyMaker. It was found that there was a problem with the input list of objects.... so you can continue trusting SkyMaker :-) ]

Hi Bertin,

I was happily enjoying the power of SkyMaker to produce artificial images when I came across with a weird unexpected behaviour.

This behaviour consists on producing wrong magnitudes (or using different zero points) in some areas of the image. To be more specific, I have constructed an image with stars with the same input magnitude. Then I've run SExtractor to measure the output magnitude and I've found that the output magnitudes change across the image, with similar values in some regions but quite different (>0.5mag) from region to region (I've checked with IRAF that the magnitudes are really different and consistent with the output of SExtractor)

I have attached a picture of the image with red circles around stars with magnitude ~14.0 and in blue stars with m~14.8.

   

I list the configuration file of SkyMaker that I've used:

IMAGE_NAME Test5.fits
IMAGE_SIZE 10500,10500
IMAGE_TYPE SKY
GRID_SIZE 64
IMAGE_HEADER INTERNAL
GAIN 1.0
WELL_CAPACITY 80000
SATUR_LEVEL 65000
READOUT_NOISE 4
EXPOSURE_TIME 35.0
MAG_ZEROPOINT 23.3829496198
PIXEL_SIZE 0.5
MICROSCAN_NSTEP 1
PSF_TYPE INTERNAL
PSF_NAME psf.fits
SEEING_TYPE SHORT_EXPOSURE
SEEING_FWHM 1.0
AUREOLE_RADIUS 200
AUREOLE_SB 16.0
PSF_OVERSAMP 20
PSF_MAPSIZE 256
TRACKERROR_TYPE NONE
TRACKERROR_MAJ 0.0
TRACKERROR_MIN 0.0
TRACKERROR_ANG 0.0
M1_DIAMETER 0.84
M2_DIAMETER 0.3029
#ARM_COUNT 4
ARM_COUNT 0
ARM_THICKNESS 2
ARM_POSANGLE 0.0
DEFOC_D80 0.0
SPHER_D80 0.0
COMAX_D80 0.0
COMAY_D80 0.0
AST00_D80 0.0
AST45_D80 0.0
TRI00_D80 0.0
TRI30_D80 0.0
QUA00_D80 0.0
QUA22_D80 0.0
WAVELENGTH 0.7
BACK_MAG 21.0
STARCOUNT_ZP 0
STARCOUNT_SLOPE 0.2
MAG_LIMITS 30,31
SEED_MOTION 0
SEED_STARPOS 0
VERBOSE_TYPE NORMAL
NTHREADS 0

I think with this information it could be possible to produce a similar image and test if this is a bogus behaviour connected with my installation of SkyMaker (I've tried the stable version 3.3.3. and the last development version 3.8.2 (2012-02-14) ) or whether I'm doing something wrong or, more unlikely, there is a bug in SkyMaker.

Cheers,

Jesús
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Wrong computed magnitudes by SkyMaker ?? - JVarela - 02-14-2012 21:12

Forum Jump:


User(s) browsing this thread: 1 Guest(s)