AstrOmatic forum
Segmentation fault when using galaxy input lists - Printable Version

+- AstrOmatic forum (https://www.astromatic.net/forum)
+-- Forum: AstrOmatic software (/forumdisplay.php?fid=3)
+--- Forum: SkyMaker (/forumdisplay.php?fid=19)
+--- Thread: Segmentation fault when using galaxy input lists (/showthread.php?tid=449)



Segmentation fault when using galaxy input lists - Lutz Haberzettl - 04-16-2009 19:31

Hi All,

I'm getting segmentation faults tying to simulate galaxies using SkyMaker 3.1.0. I'm using catalogs created by stuff as input catalogs. The segmentation fault occur when SkyMaker is reading the input catalog. It's working fine with star input lists. Can some help me with this problem?

Thanks in advance
Lutz

P.S. This is the message I get from SkyMaker
> Painting input list... (0 objects)
Segmentation fault


RE: Segmentation fault when using galaxy input lists - Henry Joy McCracken - 04-17-2009 08:48

well -- a bit more information would be appreciated: can you send the command line, as well what version you are using on what kind of machine?


RE: Segmentation fault when using galaxy input lists - Lutz Haberzettl - 04-17-2009 14:41

I'm using SkyMaker 3.1.0. I compiled the source code with threads enabled on a double processor machine with SUSE 11.1 installed. Here is the command line:

sky nuv_v2.list -c default.sky

and here is a part of the input list generated by stuff 1.17:

200 1066.568 831.441 24.6159 0.614 0.659 0.797 +96.56 0.805 0.694 +96.56 0.10091 -2.0
200 861.343 459.216 20.8354 0.021 0.677 0.946 -37.60 0.963 0.925 -37.60 0.10169 +4.0
200 -15.645 437.056 22.7720 1.000 1.169 0.977 +73.36 0.000 0.955 +73.36 0.09354 -6.0
200 751.282 257.167 22.8658 0.117 0.677 0.716 -162.81 1.288 0.297 -162.81 0.09069 +2.0
200 719.364 770.054 20.9624 0.047 0.835 1.000 -112.33 1.746 0.999 -112.33 0.09130 +2.0
200 1046.774 58.863 21.6759 0.028 0.621 0.928 +78.42 1.859 0.689 +78.42 0.09126 +4.0
200 690.004 474.430 21.7796 0.084 0.806 0.858 +79.53 1.071 0.474 +79.53 0.08843 +2.0
200 71.345 943.403 19.5941 0.054 1.213 0.854 +98.01 1.629 0.841 +98.01 0.08519 +2.0
200 943.221 686.507 20.9406 0.022 0.705 0.943 +129.57 1.565 0.913 +129.57 0.08576 +4.0
200 83.821 1003.125 20.8113 0.000 0.000 0.608 -165.52 1.449 0.333 -165.52 0.08397 +10.0
200 469.294 85.637 22.1302 1.000 1.485 0.632 +0.86 0.000 0.323 +0.86 0.07251 -6.0
200 1044.915 438.389 22.1316 0.044 0.694 0.857 +96.61 1.422 0.433 +96.61 0.06861 +4.0
200 -31.298 246.861 19.7937 0.000 0.000 0.798 -94.74 2.035 0.502 -94.74 0.06458 +10.0
200 -35.882 356.860 18.6153 0.000 0.000 0.995 +66.70 1.587 0.991 +66.70 0.06220 +10.0
200 629.827 358.545 19.7175 0.029 1.167 0.843 -5.42 2.558 0.680 -5.42 0.05805 +4.0
200 409.910 670.622 20.9813 0.063 1.061 0.773 -76.58 1.961 0.726 -76.58 0.05711 +2.0
200 780.006 1023.912 20.0306 0.031 1.155 0.915 -136.91 2.495 0.640 -136.91 0.05167 +4.0
200 1044.834 1074.782 18.8859 0.029 1.516 0.840 -150.19 7.318 0.707 -150.19 0.04798 +4.0
200 233.063 931.556 18.5451 0.004 1.005 0.926 +67.96 1.837 0.714 +67.96 0.04750 +6.0
200 716.707 397.719 18.4656 0.000 0.000 0.929 +67.70 2.557 0.895 +67.70 0.04041 +10.0
200 517.715 714.165 20.7690 0.641 2.445 0.618 -135.88 2.252 0.540 -135.88 0.03452 -2.0

I recognized that the monoprocessor version (3.1.0) on my laptop (SUSE 10.3) is working just fine.


RE: Segmentation fault when using galaxy input lists - ReiCow - 04-27-2009 04:02

I am also having Seg. Fault errors with skymapper. I have found that if I set the AUREOLE_RADIUS to 0, it no longer Seg. faults.

I am running (form the src directory.. don't want to install it until it works):
(in /path/skymapper-3.1.0/config)
>../src/sky sample.list
> WARNING: sky.conf not found, using internal defaults

----- SkyMaker 3.1.0-MP started on 2009-04-26 at 22:54:04 with 4 threads

Pupil range: 4.0-4125.3mm / Subsampling: 1X / ro=23.0cm / motion=0.00'' rms
> Painting input list... (0 objects)
Segmentation fault


(Using a file named play.list, which is sample.list with the galaxy commented out)
>../src/sky play.list

> WARNING: sky.conf not found, using internal defaults

----- SkyMaker 3.1.0-MP started on 2009-04-26 at 22:55:27 with 4 threads

Pupil range: 4.0-4125.3mm / Subsampling: 1X / ro=23.0cm / motion=0.00'' rms
> Adding diffuse component...
Segmentation fault


(Using a list file of FITS files)
>../src/sky $visible/2003-01-04/list

> WARNING: sky.conf not found, using internal defaults

----- SkyMaker 3.1.0-MP started on 2009-04-26 at 22:54:18 with 4 threads

Pupil range: 4.0-4125.3mm / Subsampling: 1X / ro=23.0cm / motion=0.00'' rms
> Adding diffuse component...
Segmentation fault

I am running Suse 10.3 on an x86_64 machine.

Thanks,
ReiCow


RE: Segmentation fault when using galaxy input lists - rshah@ll.mit.edu - 05-30-2009 01:36

Hi:

I have a related problem. I cannot seem to get a star field to be read by skymaker. I also seem to have a PSF aliasing issue.

Examples suggest that the following should work:

sky myStarList.list -c mySky.conf

where myStarList.list is from USNOB1, say, in the sample.list format for stars and mySky.conf is altered for my particular telescope.

Yet I return no response from skymaker that it has read myStarList.list:

[rshah@zero]$ sky output.list -c sky.conf
----- SkyMaker 3.1.0 started on 2009-05-29 at 21:46:46 with 1 thread

Pupil range: 0.9-924.4mm / Subsampling: 1X / ro=12.7cm / motion=0.00'' rms

> WARNING: PSF mask is too coarse (important aliasing): increase oversampling

> All done (in 141 s)


Notice the PSF mask warning. Not sure what to set the PSF sampling factor in the CONF file, and whether or not it will even be read.


RE: Segmentation fault when using galaxy input lists - Aliraza183 - 03-10-2015 12:35

You may use an external tabulated PSF model stored as a mypsf.fits (basic) FITS file using the following command-line arguments:????










__________________________________________________________________

Usman


RE: Segmentation fault when using galaxy input lists - vytieubao123 - 11-09-2015 10:27

in the sample.list format for stars and mySky